summary refs log tree commit diff
path: root/modules/system/boot/systemd-unit-options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/system/boot/systemd-unit-options.nix')
-rw-r--r--modules/system/boot/systemd-unit-options.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/system/boot/systemd-unit-options.nix b/modules/system/boot/systemd-unit-options.nix
index e3542ce9225a..be3fbd556741 100644
--- a/modules/system/boot/systemd-unit-options.nix
+++ b/modules/system/boot/systemd-unit-options.nix
@@ -76,6 +76,15 @@ rec {
       '';
     };
 
+    conflicts = mkOption {
+      default = [];
+      types = types.listOf types.string;
+      description = ''
+        If the specified units are started, then this unit is stopped
+        and vice versa.
+      '';
+    };
+
     requiredBy = mkOption {
       default = [];
       types = types.listOf types.string;