summary refs log tree commit diff
path: root/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/x11/xserver.nix')
-rw-r--r--modules/services/x11/xserver.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/services/x11/xserver.nix b/modules/services/x11/xserver.nix
index 421f80c42bbb..bfdeef81f206 100644
--- a/modules/services/x11/xserver.nix
+++ b/modules/services/x11/xserver.nix
@@ -281,6 +281,25 @@ in
         description = "Lines to be added to every Display subsection of the Screen section.";
       };
 
+      extraXorgOptions = mkOption {
+        default = "";
+        example = ''
+          Section "Monitor"
+            Identifier "left monitor"
+          EndSection
+
+          Section "Monitor"
+            Identifier "right monitor"
+            Option "RightOf" "left monitor"
+          EndSection
+        '';
+        type = types.string;
+        description = ''
+          Additional options you want to append to your X server configuration
+          file.
+        '';
+      };
+
       defaultDepth = mkOption {
         default = 0;
         example = 8;
@@ -552,6 +571,8 @@ in
 
           EndSection
         '')}
+
+        ${cfg.extraXorgOptions}
       '';
 
   });