summary refs log tree commit diff
path: root/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/x11/xserver.nix')
-rw-r--r--modules/services/x11/xserver.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/modules/services/x11/xserver.nix b/modules/services/x11/xserver.nix
index d4dc8b761bfd..c93c443287b1 100644
--- a/modules/services/x11/xserver.nix
+++ b/modules/services/x11/xserver.nix
@@ -30,7 +30,6 @@ let
     (name: { inherit name; driverName = name; } //
       attrByPath [name] (if (hasAttr ("xf86video" + name) xorg) then { modules = [(getAttr ("xf86video" + name) xorg) ]; } else throw "unknown video driver `${name}'") knownVideoDrivers);
 
-
   fontsForXServer =
     config.fonts.fonts ++
     # We don't want these fonts in fonts.conf, because then modern,
@@ -204,6 +203,15 @@ in
         '';
       };
 
+      vaapiDrivers = mkOption {
+        default = [ pkgs.vaapiIntel pkgs.vaapiVdpau ];
+        defaultText = "[ pkgs.vaapiIntel pkgs.vaapiVdpau ]";
+        example = "[ pkgs.vaapiIntel pkgs.vaapiVdpau ]";
+        description = ''
+          Names of the packages providing libva acceleration drivers.
+        '';
+      };
+
       driSupport = mkOption {
         default = true;
         description = ''