summary refs log tree commit diff
path: root/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/x11/xserver.nix')
-rw-r--r--modules/services/x11/xserver.nix37
1 files changed, 20 insertions, 17 deletions
diff --git a/modules/services/x11/xserver.nix b/modules/services/x11/xserver.nix
index 8378e10cc46b..40da6a743891 100644
--- a/modules/services/x11/xserver.nix
+++ b/modules/services/x11/xserver.nix
@@ -406,24 +406,27 @@ in
       optional (elem "virtualbox" driverNames) kernelPackages.virtualboxGuestAdditions ++
       optional (elem "ati_unfree" driverNames) kernelPackages.ati_drivers_x11;
 
+    boot.blacklistedKernelModules =
+      optionals (elem "nvidia" driverNames) [ "nouveau" "nvidiafb" ];
+
     environment.etc =
-    (optionals cfg.exportConfiguration
-      [ { source = "${configFile}";
-          target = "X11/xorg.conf";
-        }
-        # -xkbdir command line option does not seems to be passed to xkbcomp.
-        { source = "${pkgs.xkeyboard_config}/etc/X11/xkb";
-          target = "X11/xkb";
-        }
-      ])
-    ++ (optionals (elem "ati_unfree" driverNames) [
-
-        # according toiive on #ati you don't need the pcs, it is like registry... keeps old stuff to make your
-        # life harder ;) Still it seems to be required
-        { source = "${kernelPackages.ati_drivers_x11}/etc/ati";
-          target = "ati";
-        }
-    ]);
+      (optionals cfg.exportConfiguration
+        [ { source = "${configFile}";
+            target = "X11/xorg.conf";
+          }
+          # -xkbdir command line option does not seems to be passed to xkbcomp.
+          { source = "${pkgs.xkeyboard_config}/etc/X11/xkb";
+            target = "X11/xkb";
+          }
+        ])
+      ++ (optionals (elem "ati_unfree" driverNames) [
+
+          # according toiive on #ati you don't need the pcs, it is like registry... keeps old stuff to make your
+          # life harder ;) Still it seems to be required
+          { source = "${kernelPackages.ati_drivers_x11}/etc/ati";
+            target = "ati";
+          }
+      ]);
 
     environment.x11Packages =
       [ xorg.xorgserver