summary refs log tree commit diff
path: root/modules/services/networking/firewall.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/networking/firewall.nix')
-rw-r--r--modules/services/networking/firewall.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/modules/services/networking/firewall.nix b/modules/services/networking/firewall.nix
index 7bc09a7b4044..c47210c7cefb 100644
--- a/modules/services/networking/firewall.nix
+++ b/modules/services/networking/firewall.nix
@@ -108,7 +108,7 @@ in
     };
 
     networking.firewall.trustedInterfaces = mkOption {
-      type = types.list types.string;
+      type = types.listOf types.string;
       description =
         ''
           Traffic coming in from these interfaces will be accepted
@@ -119,7 +119,7 @@ in
     networking.firewall.allowedTCPPorts = mkOption {
       default = [];
       example = [ 22 80 ];
-      type = types.list types.int;
+      type = types.listOf types.int;
       description =
         ''
           List of TCP ports on which incoming connections are
@@ -130,7 +130,7 @@ in
     networking.firewall.allowedUDPPorts = mkOption {
       default = [];
       example = [ 53 ];
-      type = types.list types.int;
+      type = types.listOf types.int;
       description =
         ''
           List of open UDP ports.
@@ -168,7 +168,7 @@ in
     networking.firewall.connectionTrackingModules = mkOption {
       default = [ "ftp" ];
       example = [ "ftp" "irc" "sane" "sip" "tftp" "amanda" "h323" "netbios_sn" "pptp" "snmp" ];
-      type = types.list types.string;
+      type = types.listOf types.string;
       description =
         ''
           List of connection-tracking helpers that are auto-loaded.