about summary refs log tree commit diff
path: root/modules/nixos-hardware/lenovo/thinkpad/x230/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos-hardware/lenovo/thinkpad/x230/default.nix')
-rw-r--r--modules/nixos-hardware/lenovo/thinkpad/x230/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/nixos-hardware/lenovo/thinkpad/x230/default.nix b/modules/nixos-hardware/lenovo/thinkpad/x230/default.nix
new file mode 100644
index 000000000000..58b09f4c5d5f
--- /dev/null
+++ b/modules/nixos-hardware/lenovo/thinkpad/x230/default.nix
@@ -0,0 +1,19 @@
+{ config, lib, pkgs, ... }:
+
+{
+  imports = [
+    ../.
+    ../../../common/cpu/intel
+    ../../../common/pc/laptop/acpi_call.nix
+  ];
+
+  boot = {
+    kernelModules = [
+      "tpm-rng"
+    ];
+  };
+
+  services.xserver.deviceSection = lib.mkDefault ''
+    Option "TearFree" "true"
+  '';
+}