about summary refs log tree commit diff
path: root/modules/nixos-hardware/lenovo/thinkpad/x1/6th-gen/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos-hardware/lenovo/thinkpad/x1/6th-gen/default.nix')
-rw-r--r--modules/nixos-hardware/lenovo/thinkpad/x1/6th-gen/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/modules/nixos-hardware/lenovo/thinkpad/x1/6th-gen/default.nix b/modules/nixos-hardware/lenovo/thinkpad/x1/6th-gen/default.nix
new file mode 100644
index 000000000000..00446b8c278b
--- /dev/null
+++ b/modules/nixos-hardware/lenovo/thinkpad/x1/6th-gen/default.nix
@@ -0,0 +1,20 @@
+# A good source of information about how to fix the issues still
+# standing with kernel 4.6.11 is the following wiki page:
+# https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_X1_Carbon_(Gen_6). The
+# TrackPoint and TouchPad issues there seem to have been fixed already.
+#
+# Enable the lower-power S3 suspend state by upgrading the BIOS to version >= 1.30,
+# then manually selecting Linux in the power management section.
+{ config, pkgs, lib, ... }:
+{
+  imports = [
+    ../.
+    ../../../../common/pc/laptop/acpi_call.nix
+  ];
+
+  # New ThinkPads have a different TrackPoint manufacturer/name.
+  # See also https://certification.ubuntu.com/catalog/component/input/5313/input%3ATPPS/2ElanTrackPoint/
+  hardware.trackpoint.device = "TPPS/2 Elan TrackPoint";
+
+  services.throttled.enable = lib.mkDefault true;
+}