about summary refs log tree commit diff
path: root/modules/nixos-hardware/lenovo/thinkpad/t440p/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos-hardware/lenovo/thinkpad/t440p/default.nix')
-rw-r--r--modules/nixos-hardware/lenovo/thinkpad/t440p/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/nixos-hardware/lenovo/thinkpad/t440p/default.nix b/modules/nixos-hardware/lenovo/thinkpad/t440p/default.nix
new file mode 100644
index 000000000000..4dd4085794fa
--- /dev/null
+++ b/modules/nixos-hardware/lenovo/thinkpad/t440p/default.nix
@@ -0,0 +1,16 @@
+{ config, lib, pkgs, ... }:
+
+{
+  imports = [
+    ../.
+    ../../../common/cpu/intel
+  ];
+
+  boot = {
+    extraModprobeConfig = lib.mkDefault ''
+      options bbswitch use_acpi_to_detect_card_state=1
+    '';
+    # TODO: probably enable tcsd? Is this line necessary?
+    kernelModules = [ "tpm-rng" ];
+  };
+}