about summary refs log tree commit diff
path: root/modules/nixos-hardware/lenovo/thinkpad/t410/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos-hardware/lenovo/thinkpad/t410/default.nix')
-rw-r--r--modules/nixos-hardware/lenovo/thinkpad/t410/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/modules/nixos-hardware/lenovo/thinkpad/t410/default.nix b/modules/nixos-hardware/lenovo/thinkpad/t410/default.nix
new file mode 100644
index 000000000000..c40801ffc0bc
--- /dev/null
+++ b/modules/nixos-hardware/lenovo/thinkpad/t410/default.nix
@@ -0,0 +1,36 @@
+{ config, lib, pkgs, ... }:
+
+{
+  imports = [
+    ../.
+    ../tp-smapi.nix
+    ../../../common/cpu/intel
+  ];
+
+  boot = {
+    # TODO: this configuration seems to be very aggressive.
+    # Ask @peti if it's stable or not.
+    kernelParams = [
+      "drm.debug=0"
+      "drm.vblankoffdelay=1"
+      "i915.semaphores=1"
+      "i915.modeset=1"
+      "i915.use_mmio_flip=1"
+      "i915.powersave=1"
+      "i915.enable_ips=1"
+      "i915.disable_power_well=1"
+      "i915.enable_hangcheck=1"
+      "i915.enable_cmd_parser=1"
+      "i915.fastboot=0"
+      "i915.enable_ppgtt=1"
+      "i915.reset=0"
+      "i915.lvds_use_ssc=0"
+      "i915.enable_psr=0"
+      "vblank_mode=0"
+      "i915.i915_enable_rc6=1"
+    ];
+    blacklistedKernelModules = [
+      "sierra_net" "cdc_mbim" "cdc_ncm" "btusb"
+    ];
+  };
+}