about summary refs log tree commit diff
path: root/modules/nixos-hardware/dell/xps/15-9500/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos-hardware/dell/xps/15-9500/default.nix')
-rw-r--r--modules/nixos-hardware/dell/xps/15-9500/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/nixos-hardware/dell/xps/15-9500/default.nix b/modules/nixos-hardware/dell/xps/15-9500/default.nix
new file mode 100644
index 000000000000..c7beda4d558e
--- /dev/null
+++ b/modules/nixos-hardware/dell/xps/15-9500/default.nix
@@ -0,0 +1,21 @@
+{ lib, ... }:
+let
+  thermald-conf = ./thermald-conf.xml;
+in
+{
+  imports = [
+    ../../../common/cpu/intel
+    ../../../common/pc/laptop
+    ../../../common/pc/laptop/ssd
+  ];
+
+  # Boot loader
+  boot.kernelParams = lib.mkDefault [ "acpi_rev_override" ];
+
+  # This will save you money and possibly your life!
+  services.thermald.enable = lib.mkDefault true;
+
+  # Thermald doesn't have a default config for the 9500 yet, the one in this repo
+  # was generated with dptfxtract-static (https://github.com/intel/dptfxtract)
+  services.thermald.configFile = lib.mkDefault thermald-conf;
+}