about summary refs log tree commit diff
path: root/modules/nixos-hardware/dell/g3/3779/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos-hardware/dell/g3/3779/default.nix')
-rw-r--r--modules/nixos-hardware/dell/g3/3779/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/modules/nixos-hardware/dell/g3/3779/default.nix b/modules/nixos-hardware/dell/g3/3779/default.nix
new file mode 100644
index 000000000000..8c9b3d328bd0
--- /dev/null
+++ b/modules/nixos-hardware/dell/g3/3779/default.nix
@@ -0,0 +1,24 @@
+{ lib, pkgs, ... }:
+
+{
+  imports = [
+    ../../../common/cpu/intel
+    ../../../common/gpu/nvidia.nix
+    ../../../common/pc/laptop
+    ../../../common/pc/laptop/ssd
+  ];
+
+  # Specify bus id of Nvidia and Intel graphics
+  hardware.nvidia.prime = {
+    intelBusId = "PCI:0:2:0";
+    nvidiaBusId = "PCI:1:0:0";
+  };
+
+  # Cooling management
+  services.thermald.enable = lib.mkDefault true;
+
+  # Use same ACPI identifier as Dell Ubuntu
+  boot.kernelParams = [
+    "acpi_osi=Linux-Dell-Video"
+  ];
+}