about summary refs log tree commit diff
path: root/modules/nixos-hardware/apple/macbook-pro/10-1/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos-hardware/apple/macbook-pro/10-1/default.nix')
-rw-r--r--modules/nixos-hardware/apple/macbook-pro/10-1/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/nixos-hardware/apple/macbook-pro/10-1/default.nix b/modules/nixos-hardware/apple/macbook-pro/10-1/default.nix
new file mode 100644
index 000000000000..e029ef21ecac
--- /dev/null
+++ b/modules/nixos-hardware/apple/macbook-pro/10-1/default.nix
@@ -0,0 +1,21 @@
+{ lib, pkgs, ... }:
+
+{
+  imports = [
+    ../.
+    ../../../common/pc/laptop/ssd
+  ];
+
+  # TODO: boot loader
+  boot.loader.systemd-boot.enable = true;
+  boot.loader.efi.canTouchEfiVariables = true;
+
+  # TODO: reverse compat
+  hardware.opengl.driSupport32Bit = true;
+
+  services.xserver = {
+    # TODO: we should not enable unfree drivers
+    # when there is an alternative (i.e. nouveau)
+    videoDrivers = [ "nvidia" ];
+  };
+}