about summary refs log tree commit diff
path: root/modules/nixos-hardware/apple/macbook-air/6/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos-hardware/apple/macbook-air/6/default.nix')
-rw-r--r--modules/nixos-hardware/apple/macbook-air/6/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/nixos-hardware/apple/macbook-air/6/default.nix b/modules/nixos-hardware/apple/macbook-air/6/default.nix
new file mode 100644
index 000000000000..555d70418b85
--- /dev/null
+++ b/modules/nixos-hardware/apple/macbook-air/6/default.nix
@@ -0,0 +1,18 @@
+{ config, lib, ... }:
+
+{
+  imports = [ ../. ];
+
+  boot = {
+    extraModulePackages = with config.boot.kernelPackages; [ mba6x_bl ];
+    kernelModules = [ "mba6x_bl" ];
+
+    # Divides power consumption by two.
+    kernelParams = [ "acpi_osi=" ];
+  };
+
+  services.xserver.deviceSection = lib.mkDefault ''
+    Option "Backlight" "mba6x_backlight"
+    Option "TearFree" "true"
+  '';
+}