about summary refs log tree commit diff
path: root/modules/nixos-hardware/apple/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos-hardware/apple/default.nix')
-rw-r--r--modules/nixos-hardware/apple/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/modules/nixos-hardware/apple/default.nix b/modules/nixos-hardware/apple/default.nix
new file mode 100644
index 000000000000..a2ee26230aaa
--- /dev/null
+++ b/modules/nixos-hardware/apple/default.nix
@@ -0,0 +1,12 @@
+{ config, lib, ... }:
+
+{
+  boot.kernelParams = [
+    "hid_apple.iso_layout=0"
+  ];
+
+  hardware.facetimehd.enable = lib.mkDefault
+    (config.nixpkgs.config.allowUnfree or false);
+
+  services.mbpfan.enable = lib.mkDefault true;
+}