summary refs log tree commit diff
path: root/modules/misc/crashdump.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/misc/crashdump.nix')
-rw-r--r--modules/misc/crashdump.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/misc/crashdump.nix b/modules/misc/crashdump.nix
index fff459c9ab43..973abfd93270 100644
--- a/modules/misc/crashdump.nix
+++ b/modules/misc/crashdump.nix
@@ -48,9 +48,9 @@ in
   config = mkIf crashdump.enable {
     boot = {
       postBootCommands = ''
-        ${pkgs.kexectools}/sbin/kexec -p /var/run/current-system/kernel \
-        --initrd=/var/run/current-system/initrd \
-        --append="init=$(readlink -f /var/run/current-system/init) system=$(readlink -f /var/run/current-system) irqpoll maxcpus=1 reset_devices ${kernelParams}" --reset-vga --console-vga
+        ${pkgs.kexectools}/sbin/kexec -p /run/current-system/kernel \
+        --initrd=/run/current-system/initrd \
+        --append="init=$(readlink -f /run/current-system/init) system=$(readlink -f /run/current-system) irqpoll maxcpus=1 reset_devices ${kernelParams}" --reset-vga --console-vga
       '';
       kernelParams = [
        "crashkernel=64M"