summary refs log tree commit diff
path: root/modules/installer/cd-dvd/installation-cd-base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/installer/cd-dvd/installation-cd-base.nix')
-rw-r--r--modules/installer/cd-dvd/installation-cd-base.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/modules/installer/cd-dvd/installation-cd-base.nix b/modules/installer/cd-dvd/installation-cd-base.nix
index 31f803bac328..999871ab074f 100644
--- a/modules/installer/cd-dvd/installation-cd-base.nix
+++ b/modules/installer/cd-dvd/installation-cd-base.nix
@@ -7,8 +7,7 @@ with pkgs.lib;
 
 {
   imports =
-    [ ./memtest.nix
-      ./channel.nix
+    [ ./channel.nix
       ./iso-image.nix
 
       # Profiles of this basic installation CD.
@@ -32,4 +31,7 @@ with pkgs.lib;
   # To speed up installation a little bit, include the complete stdenv
   # in the Nix store on the CD.
   isoImage.storeContents = [ pkgs.stdenv pkgs.busybox ];
+
+  # Add Memtest86+ to the CD.
+  boot.loader.grub.memtest86 = true;
 }