summary refs log tree commit diff
path: root/modules/config/timezone.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/config/timezone.nix')
-rw-r--r--modules/config/timezone.nix20
1 files changed, 14 insertions, 6 deletions
diff --git a/modules/config/timezone.nix b/modules/config/timezone.nix
index 5dcf38c462d4..38c698bc21c0 100644
--- a/modules/config/timezone.nix
+++ b/modules/config/timezone.nix
@@ -5,13 +5,21 @@ with pkgs.lib;
 {
   options = {
 
-    time.timeZone = mkOption {
-      default = "CET";
-      type = with types; uniq string;
-      example = "America/New_York";
-      description = "The time zone used when displaying times and dates.";
-    };
+    time = {
+    
+      timeZone = mkOption {
+        default = "CET";
+        type = with types; uniq string;
+        example = "America/New_York";
+        description = "The time zone used when displaying times and dates.";
+      };
 
+      hardwareClockInLocalTime = mkOption {
+        default = false;
+        description = "If set, keep the hardware clock in local time instead of UTC.";
+      };
+      
+    };
   };
 
   config = {