about summary refs log tree commit diff
path: root/lib/tests/misc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/tests/misc.nix')
-rw-r--r--lib/tests/misc.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/tests/misc.nix b/lib/tests/misc.nix
index c719fcf5d4fa..7e52a2e8f0ab 100644
--- a/lib/tests/misc.nix
+++ b/lib/tests/misc.nix
@@ -459,6 +459,11 @@ runTests {
     expected = [2 30 40 42];
   };
 
+  testReplicate = {
+    expr = replicate 3 "a";
+    expected = ["a" "a" "a"];
+  };
+
   testToIntShouldConvertStringToInt = {
     expr = toInt "27";
     expected = 27;