about summary refs log tree commit diff
path: root/lib/tests/maintainers.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/tests/maintainers.nix')
-rw-r--r--lib/tests/maintainers.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/tests/maintainers.nix b/lib/tests/maintainers.nix
index f82b63649b1f..cb1e9ddd5288 100644
--- a/lib/tests/maintainers.nix
+++ b/lib/tests/maintainers.nix
@@ -30,6 +30,8 @@ let
         echo -e "    githubId = $id;\n"
       '' ++ lib.optional (checkedAttrs.email == null && checkedAttrs.github == null && checkedAttrs.matrix == null) ''
         echo ${lib.escapeShellArg (lib.showOption prefix)}': At least one of `email`, `github` or `matrix` must be specified, so that users know how to reach you.'
+      '' ++ lib.optional (checkedAttrs.email != null && lib.hasSuffix "noreply.github.com" checkedAttrs.email) ''
+        echo ${lib.escapeShellArg (lib.showOption prefix)}': If an email address is given, it should allow people to reach you. If you do not want that, you can just provide `github` or `matrix` instead.'
       '';
     in lib.deepSeq checkedAttrs checks;