summary refs log tree commit diff
path: root/lib/systems/examples.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/systems/examples.nix')
-rw-r--r--lib/systems/examples.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/lib/systems/examples.nix b/lib/systems/examples.nix
index 8ba03a63fd8d..a40c38924245 100644
--- a/lib/systems/examples.nix
+++ b/lib/systems/examples.nix
@@ -99,6 +99,34 @@ rec {
   riscv64 = riscv "64";
   riscv32 = riscv "32";
 
+  avr = {
+    config = "avr";
+  };
+
+  arm-embedded = {
+    config = "arm-none-eabi";
+    libc = "newlib";
+  };
+
+  aarch64-embedded = {
+    config = "aarch64-none-elf";
+    libc = "newlib";
+  };
+
+  ppc-embedded = {
+    config = "powerpc-none-eabi";
+    libc = "newlib";
+  };
+
+  i686-embedded = {
+    config = "i686-elf";
+    libc = "newlib";
+  };
+
+  x86_64-embedded = {
+    config = "x86_64-elf";
+    libc = "newlib";
+  };
 
   #
   # Darwin