summary refs log tree commit diff
path: root/lib/systems/doubles.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/systems/doubles.nix')
-rw-r--r--lib/systems/doubles.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/lib/systems/doubles.nix b/lib/systems/doubles.nix
index ac1a199d80c4..0cae8ec56fdf 100644
--- a/lib/systems/doubles.nix
+++ b/lib/systems/doubles.nix
@@ -1,8 +1,9 @@
+{ lib }:
 let
-  lists = import ../lists.nix;
-  parse = import ./parse.nix;
-  inherit (import ./inspect.nix) predicates;
-  inherit (import ../attrsets.nix) matchAttrs;
+  inherit (lib) lists;
+  parse = import ./parse.nix { inherit lib; };
+  inherit (import ./inspect.nix { inherit lib; }) predicates;
+  inherit (lib.attrsets) matchAttrs;
 
   all = [
     "aarch64-linux"