summary refs log tree commit diff
path: root/lib/systems/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/systems/default.nix')
-rw-r--r--lib/systems/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/systems/default.nix b/lib/systems/default.nix
index a61e4efc4ef8..c37b6be25232 100644
--- a/lib/systems/default.nix
+++ b/lib/systems/default.nix
@@ -21,6 +21,12 @@ rec {
       config = parse.tripleFromSystem final.parsed;
       # Just a guess, based on `system`
       platform = platforms.selectBySystem final.system;
+      libc =
+        /**/ if final.isDarwin then "libSystem"
+        else if final.isMinGW  then "msvcrt"
+        else if final.isLinux  then "glibc"
+        # TODO(@Ericson2314) think more about other operating systems
+        else                        "native/impure";
     } // mapAttrs (n: v: v final.parsed) inspect.predicates
       // args;
   in final;