summary refs log tree commit diff
path: root/lib/systems.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/systems.nix')
-rw-r--r--lib/systems.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/systems.nix b/lib/systems.nix
index 25a83e9d14fa..92d8bdf892b4 100644
--- a/lib/systems.nix
+++ b/lib/systems.nix
@@ -84,10 +84,10 @@ rec {
   };
 
 
+  is64Bit = matchAttrs { cpu = { bits = 64; }; };
   isDarwin = matchAttrs { kernel = kernels.darwin; };
-  isLinux = matchAttrs { kernel = kernels.linux; };
   isi686 = matchAttrs { cpu = cpuTypes.i686; };
-  is64Bit = matchAttrs { cpu = { bits = 64; }; };
+  isLinux = matchAttrs { kernel = kernels.linux; };
 
 
   # This should revert the job done by config.guess from the gcc compiler.