summary refs log tree commit diff
path: root/lib/options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/options.nix')
-rw-r--r--lib/options.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/lib/options.nix b/lib/options.nix
index efb32efc6356..b6a88008bb7a 100644
--- a/lib/options.nix
+++ b/lib/options.nix
@@ -11,10 +11,7 @@ with import ./properties.nix;
 
 rec {
 
-  inherit (lib) isType;
-  
-
-  isOption = isType "option";
+  isOption = lib.isType "option";
   mkOption = attrs: attrs // {
     _type = "option";
     # name (this is the name of the attributem it is automatically generated by the traversal)
@@ -66,7 +63,7 @@ rec {
               if all opt.check list then
                 opt.merge list
               else
-                throw "One of option ${name} values has a bad type.";
+                throw "A value of the option `${name}' has a bad type.";
           }
         else opt;
 
@@ -77,7 +74,7 @@ rec {
               if opt.check opt.default then
                 opt.default
               else
-                throw "The default value of option ${name} has a bad type.";
+                throw "The default value of the option `${name}' has a bad type.";
           }
         else opt;