summary refs log tree commit diff
path: root/lib/licenses.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/licenses.nix')
-rw-r--r--lib/licenses.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/licenses.nix b/lib/licenses.nix
index d4810d412b1d..08376b7e7e0e 100644
--- a/lib/licenses.nix
+++ b/lib/licenses.nix
@@ -130,6 +130,16 @@ lib.mapAttrs (n: v: v // { shortName = n; }) rec {
     fullName = "Common Public License 1.0";
   };
 
+  efl10 = spdx {
+    spdxId = "EFL-1.0";
+    fullName = "Eiffel Forum License v1.0";
+  };
+
+  efl20 = spdx {
+    spdxId = "EFL-2.0";
+    fullName = "Eiffel Forum License v2.0";
+  };
+
   epl10 = spdx {
     spdxId = "EPL-1.0";
     fullName = "Eclipse Public License 1.0";
@@ -287,6 +297,11 @@ lib.mapAttrs (n: v: v // { shortName = n; }) rec {
     fullName = "MIT License";
   };
 
+  mpl10 = spdx {
+    spdxId = "MPL-1.0";
+    fullName = "Mozilla Public License 1.0";
+  };
+
   mpl11 = spdx {
     spdxId = "MPL-1.1";
     fullName = "Mozilla Public License 1.1";