summary refs log tree commit diff
path: root/lib/licenses.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/licenses.nix')
-rw-r--r--lib/licenses.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/licenses.nix b/lib/licenses.nix
index 611e6ddb35b7..092cbbbdb25a 100644
--- a/lib/licenses.nix
+++ b/lib/licenses.nix
@@ -309,6 +309,12 @@ lib.mapAttrs (n: v: v // { shortName = n; }) rec {
     fullName = "GNU General Public License v2.0 only";
   };
 
+  gpl2Classpath = {
+    spdxId = "GPL-2.0-with-classpath-exception";
+    fullName = "GNU General Public License v2.0 only (with Classpath exception)";
+    url = https://fedoraproject.org/wiki/Licensing/GPL_Classpath_Exception;
+  };
+
   gpl2ClasspathPlus = {
     fullName = "GNU General Public License v2.0 or later (with Classpath exception)";
     url = https://fedoraproject.org/wiki/Licensing/GPL_Classpath_Exception;
@@ -394,6 +400,10 @@ lib.mapAttrs (n: v: v // { shortName = n; }) rec {
     free = false;
   };
 
+  jasper = spdx {
+    spdxId = "JasPer-2.0";
+    fullName = "JasPer License";
+  };
 
   lgpl2 = spdx {
     spdxId = "LGPL-2.0";