about summary refs log tree commit diff
path: root/lib/kernel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/kernel.nix')
-rw-r--r--lib/kernel.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/kernel.nix b/lib/kernel.nix
index ffcbc268b76c..33da9663a8ed 100644
--- a/lib/kernel.nix
+++ b/lib/kernel.nix
@@ -8,9 +8,10 @@ with lib;
   option = x:
       x // { optional = true; };
 
-  yes      = { tristate    = "y"; optional = false; };
-  no       = { tristate    = "n"; optional = false; };
-  module   = { tristate    = "m"; optional = false; };
+  yes      = { tristate    = "y";  optional = false; };
+  no       = { tristate    = "n";  optional = false; };
+  module   = { tristate    = "m";  optional = false; };
+  unset    = { tristate    = null; optional = false; };
   freeform = x: { freeform = x; optional = false; };
 
   /*