about summary refs log tree commit diff
path: root/lib/deprecated.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/deprecated.nix')
-rw-r--r--lib/deprecated.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/deprecated.nix b/lib/deprecated.nix
index 45a3893fc22d..983e8d26892b 100644
--- a/lib/deprecated.nix
+++ b/lib/deprecated.nix
@@ -253,11 +253,11 @@ rec {
   # eg { a = 7; } {  a = [ 2 3 ]; } becomes { a = [ 7 2 3 ]; }
   mergeAttrsConcatenateValues = mergeAttrsWithFunc ( a: b: (toList a) ++ (toList b) );
 
-  # merges attributes using //, if a name exisits in both attributes
+  # merges attributes using //, if a name exists in both attributes
   # an error will be triggered unless its listed in mergeLists
   # so you can mergeAttrsNoOverride { buildInputs = [a]; } { buildInputs = [a]; } {} to get
   # { buildInputs = [a b]; }
-  # merging buildPhase does'nt really make sense. The cases will be rare where appending /prefixing will fit your needs?
+  # merging buildPhase doesn't really make sense. The cases will be rare where appending /prefixing will fit your needs?
   # in these cases the first buildPhase will override the second one
   # ! deprecated, use mergeAttrByFunc instead
   mergeAttrsNoOverride = { mergeLists ? ["buildInputs" "propagatedBuildInputs"],