summary refs log tree commit diff
path: root/lib/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/lib/default.nix b/lib/default.nix
new file mode 100644
index 000000000000..fc92e04503b2
--- /dev/null
+++ b/lib/default.nix
@@ -0,0 +1,32 @@
+let 
+
+  trivial = import ./trivial.nix;
+  lists = import ./lists.nix;
+  strings = import ./strings.nix;
+  stringsWithDeps = import ./strings-with-deps.nix;
+  attrsets = import ./attrsets.nix;
+  sources = import ./sources.nix;
+  modules = import ./modules.nix;
+  options = import ./options.nix;
+  types = import ./types.nix;
+  meta = import ./meta.nix;
+  debug = import ./debug.nix;
+  misc = import ./misc.nix;
+  maintainers = import ./maintainers.nix;
+  platforms = import ./platforms.nix;
+  systems = import ./systems.nix;
+  customisation = import ./customisation.nix;
+  licenses = import ./licenses.nix;
+
+in
+  { inherit trivial lists strings stringsWithDeps attrsets sources options
+      modules types meta debug maintainers licenses platforms systems;
+    # Pull in some builtins not included elsewhere.
+    inherit (builtins) pathExists readFile;
+  }
+  # !!! don't include everything at top-level; perhaps only the most
+  # commonly used functions.
+  // trivial // lists // strings // stringsWithDeps // attrsets // sources
+  // options // types // meta // debug // misc // modules
+  // systems
+  // customisation