about summary refs log tree commit diff
path: root/doc/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'doc/shell.nix')
-rw-r--r--doc/shell.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/doc/shell.nix b/doc/shell.nix
new file mode 100644
index 000000000000..d71e3f3a709a
--- /dev/null
+++ b/doc/shell.nix
@@ -0,0 +1,20 @@
+let
+  pkgs = import ../. {
+    config = {};
+    overlays = [];
+  };
+
+  common = import ./common.nix;
+  inherit (common) outputPath indexPath;
+
+  web-devmode = import ../pkgs/tools/nix/web-devmode.nix {
+    inherit pkgs;
+    buildArgs = "./.";
+    open = "/${outputPath}/${indexPath}";
+  };
+in
+  pkgs.mkShell {
+    packages = [
+      web-devmode
+    ];
+  }