about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix36
1 files changed, 12 insertions, 24 deletions
diff --git a/default.nix b/default.nix
index faed7e263540..285cd9177089 100644
--- a/default.nix
+++ b/default.nix
@@ -1,28 +1,16 @@
-let requiredVersion = import ./lib/minver.nix; in
+{ overlays ? [] } @ args:
 
-if ! builtins ? nixVersion || builtins.compareVersions requiredVersion builtins.nixVersion == 1 then
+let
+  inherit (builtins) attrNames filter match pathExists readDir;
 
-  abort ''
+  path = ./overlays;
 
-    This version of Nixpkgs requires Nix >= ${requiredVersion}, please upgrade:
+  overlayPaths =
+    filter
+      (n: match ".*\\.nix" n != null || pathExists (path + "/${n}/default.nix"))
+      (attrNames (readDir path));
 
-    - If you are running NixOS, `nixos-rebuild' can be used to upgrade your system.
-
-    - Alternatively, with Nix > 2.0 `nix upgrade-nix' can be used to imperatively
-      upgrade Nix. You may use `nix-env --version' to check which version you have.
-
-    - If you installed Nix using the install script (https://nixos.org/nix/install),
-      it is safe to upgrade by running it again:
-
-          curl -L https://nixos.org/nix/install | sh
-
-    For more information, please see the NixOS release notes at
-    https://nixos.org/nixos/manual or locally at
-    ${toString ./nixos/doc/manual/release-notes}.
-
-    If you need further help, see https://nixos.org/nixos/support.html
-  ''
-
-else
-
-  import ./pkgs/top-level/impure.nix
+in
+  import ./nixpkgs (args // {
+    overlays = (map (n: import (path + "/${n}")) overlayPaths) ++ overlays;
+  })