summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-12-30 12:26:35 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2017-12-31 11:01:52 +0100
commitfd0b0190075552cbffca5386038b6fac8c1880bd (patch)
tree1e40901882c6796964efaf2848665fa4c1a63357 /pkgs/top-level
parent6801d20ac790e973c9a093b345d2a02d2bb72833 (diff)
downloadnixlib-fd0b0190075552cbffca5386038b6fac8c1880bd.tar
nixlib-fd0b0190075552cbffca5386038b6fac8c1880bd.tar.gz
nixlib-fd0b0190075552cbffca5386038b6fac8c1880bd.tar.bz2
nixlib-fd0b0190075552cbffca5386038b6fac8c1880bd.tar.lz
nixlib-fd0b0190075552cbffca5386038b6fac8c1880bd.tar.xz
nixlib-fd0b0190075552cbffca5386038b6fac8c1880bd.tar.zst
nixlib-fd0b0190075552cbffca5386038b6fac8c1880bd.zip
python: pytest: 3.2.5 -> 3.3.1
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index b84f29d4d144..270330cdcde1 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -3436,7 +3436,7 @@ in {
     };
   };
 
-  pytest = self.pytest_32;
+  pytest = self.pytest_33;
 
   pytest_27 = callPackage ../development/python-modules/pytest/2_7.nix {};
 
@@ -3451,7 +3451,16 @@ in {
       pytest = null;
     };
   };
-  pytest_32 = callPackage ../development/python-modules/pytest{
+
+  pytest_32 = callPackage ../development/python-modules/pytest/3_2.nix{
+    hypothesis = self.hypothesis.override {
+      # hypothesis requires pytest that causes dependency cycle
+      doCheck = false;
+      pytest = null;
+    };
+  };
+
+  pytest_33 = callPackage ../development/python-modules/pytest/default.nix{
     hypothesis = self.hypothesis.override {
       # hypothesis requires pytest that causes dependency cycle
       doCheck = false;