summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMichael Brantley <limeytexan@gmail.com>2018-02-28 10:49:09 +0000
committerJörg Thalheim <Mic92@users.noreply.github.com>2018-02-28 10:49:09 +0000
commitf0e0bd18ed804d2b2b4105b450e3ce2b2143660a (patch)
tree952826fbde8705adffb8de869af4f4734ba2bc1b /pkgs/top-level
parent393644e28c039a9243aae85571c0dd548982b6df (diff)
downloadnixlib-f0e0bd18ed804d2b2b4105b450e3ce2b2143660a.tar
nixlib-f0e0bd18ed804d2b2b4105b450e3ce2b2143660a.tar.gz
nixlib-f0e0bd18ed804d2b2b4105b450e3ce2b2143660a.tar.bz2
nixlib-f0e0bd18ed804d2b2b4105b450e3ce2b2143660a.tar.lz
nixlib-f0e0bd18ed804d2b2b4105b450e3ce2b2143660a.tar.xz
nixlib-f0e0bd18ed804d2b2b4105b450e3ce2b2143660a.tar.zst
nixlib-f0e0bd18ed804d2b2b4105b450e3ce2b2143660a.zip
perlPackages.Mail-Sendmail: init at 0.80 (#35223)
* perl-Mail-Sendmail: init at 0.80

* Disabled unit test that could never succeed in sandbox
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/perl-packages.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/top-level/perl-packages.nix b/pkgs/top-level/perl-packages.nix
index 7608e6d83470..30afb74e82e7 100644
--- a/pkgs/top-level/perl-packages.nix
+++ b/pkgs/top-level/perl-packages.nix
@@ -8475,6 +8475,27 @@ let self = _self // overrides; _self = with self; {
     };
   };
 
+  MailSendmail = buildPerlPackage rec {
+    name = "Mail-Sendmail-0.80";
+    src = fetchurl {
+      url = "mirror://cpan/authors/id/N/NE/NEILB/Mail-Sendmail-0.80.tar.gz";
+      sha256 = "1r38qbkj7jwj8cqy1rnqzkk81psxi08b1aiq392817f3bk5ri2jv";
+    };
+    propagatedBuildInputs = [ DigestMD5 MIMEBase64 Socket TimeLocal ];
+    # The test suite simply loads the module and attempts to send an email to
+    # the module's author, the latter of which is a) more of an integration
+    # test, b) impossible to verify, and c) won't work from a sandbox. Replace
+    # it in its entirety with the following simple smoke test.
+    checkPhase = ''
+      perl -I blib/lib -MMail::Sendmail -e 'print "1..1\nok 1\n"'
+    '';
+    meta = {
+      maintainers = [ maintainers.limeytexan ];
+      description = "Simple platform independent mailer";
+      license = with stdenv.lib.licenses; [ artistic1 gpl1Plus ];
+    };
+  };
+
   MailSPF = buildPerlPackage rec {
     name = "Mail-SPF-v2.9.0";
     #src = /root/nixops/Mail-SPF-v2.9.0;