summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2016-03-12 19:04:40 -0500
committerFrederik Rietdijk <fridh@fridh.nl>2016-03-16 17:55:52 -0400
commitefd6e1884cc49d2a91d6e52880bdf651cfc431a0 (patch)
tree754e6595cc422d767771bcd9a20e455a8afc4241 /pkgs/top-level
parent8585441ae5266c7b428d68e301cf677545da4eb9 (diff)
downloadnixlib-efd6e1884cc49d2a91d6e52880bdf651cfc431a0.tar
nixlib-efd6e1884cc49d2a91d6e52880bdf651cfc431a0.tar.gz
nixlib-efd6e1884cc49d2a91d6e52880bdf651cfc431a0.tar.bz2
nixlib-efd6e1884cc49d2a91d6e52880bdf651cfc431a0.tar.lz
nixlib-efd6e1884cc49d2a91d6e52880bdf651cfc431a0.tar.xz
nixlib-efd6e1884cc49d2a91d6e52880bdf651cfc431a0.tar.zst
nixlib-efd6e1884cc49d2a91d6e52880bdf651cfc431a0.zip
pythonPackages.pandas_17: init at 0.17.1
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 9b330d8c8202..bdb170b71168 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -14570,7 +14570,7 @@ in modules // {
     };
   };
 
-  pandas = let
+  pandas_17 = let
     inherit (pkgs.stdenv.lib) optional optionalString;
     inherit (pkgs.stdenv) isDarwin;
   in buildPythonPackage rec {
@@ -14585,16 +14585,14 @@ in modules // {
     buildInputs = with self; [ nose ] ++ optional isDarwin pkgs.libcxx;
     propagatedBuildInputs = with self; [
       dateutil
-      numpy
-      scipy
+      scipy_0_17
       numexpr
       pytz
       xlrd
       bottleneck
       sqlalchemy
       lxml
-      # Disabling this because an upstream dependency, pep8, is broken on v3.5.
-      (if isPy35 then null else html5lib)
+      html5lib
       modules.sqlite3
       beautifulsoup4
     ] ++ optional isDarwin pkgs.darwin.locale; # provides the locale command
@@ -14630,7 +14628,7 @@ in modules // {
       runHook preCheck
       # The flag `-A 'not network'` will disable tests that use internet.
       # The `-e` flag disables a few problematic tests.
-      ${python.executable} setup.py nosetests -A 'not network' --stop \
+      ${python.executable} setup.py nosetests -A 'not slow and not network' --stop \
         -e '${concatStringsSep "|" testsToSkip}' --verbosity=3
 
       runHook postCheck