summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorAlexander V. Nikolaev <avn@avnik.info>2018-02-24 15:38:25 +0200
committerAlexander V. Nikolaev <avn@avnik.info>2018-02-24 17:06:49 +0200
commite94cd63bf50781ab65c7d4387f1abeaf4bd7841e (patch)
tree623fcaf0ca412d786f83e73ef08ed5efa4431b07 /pkgs/top-level
parent0acec7e984ff38b7a296a459ba4b539a3b719c1b (diff)
downloadnixlib-e94cd63bf50781ab65c7d4387f1abeaf4bd7841e.tar
nixlib-e94cd63bf50781ab65c7d4387f1abeaf4bd7841e.tar.gz
nixlib-e94cd63bf50781ab65c7d4387f1abeaf4bd7841e.tar.bz2
nixlib-e94cd63bf50781ab65c7d4387f1abeaf4bd7841e.tar.lz
nixlib-e94cd63bf50781ab65c7d4387f1abeaf4bd7841e.tar.xz
nixlib-e94cd63bf50781ab65c7d4387f1abeaf4bd7841e.tar.zst
nixlib-e94cd63bf50781ab65c7d4387f1abeaf4bd7841e.zip
treewide: transition libGL/libGLU for qt
Also rename mesaSupported to libGLSupported
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 54666152c87c..6d3bcc3b23fa 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -10390,7 +10390,7 @@ with pkgs;
   # Default derivation with libGL.so.1 to link into /run/opengl-drivers (if need)
   libGL_driver = mesa_drivers;
 
-  mesaSupported = lib.elem system lib.platforms.mesaPlatforms;
+  libGLSupported = lib.elem system lib.platforms.mesaPlatforms;
 
   libGLDarwinOr = alternative: if stdenv.isDarwin
     then callPackage ../development/libraries/mesa-darwin {
@@ -10853,7 +10853,7 @@ with pkgs;
   qoauth = callPackage ../development/libraries/qoauth { };
 
   qt3 = callPackage ../development/libraries/qt-3 {
-    openglSupport = mesaSupported;
+    openglSupport = libGLSupported;
     libpng = libpng12;
   };
 
@@ -10861,13 +10861,13 @@ with pkgs;
 
   qt48 = callPackage ../development/libraries/qt-4.x/4.8 {
     # GNOME dependencies are not used unless gtkStyle == true
-    mesa = mesa_noglu;
     inherit (pkgs.gnome2) libgnomeui GConf gnome_vfs;
     cups = if stdenv.isLinux then cups else null;
 
     # XXX: mariadb doesn't built on fbsd as of nov 2015
     mysql = if (!stdenv.isFreeBSD) then mysql else null;
 
+    inherit libGL;
     inherit (pkgs.darwin) cf-private libobjc;
     inherit (pkgs.darwin.apple_sdk.frameworks) ApplicationServices OpenGL Cocoa AGL;
   };
@@ -10892,7 +10892,7 @@ with pkgs;
       bison = bison2; # error: too few arguments to function 'int yylex(...
       inherit cups;
       harfbuzz = harfbuzz-icu;
-      mesa = mesa_noglu;
+      inherit libGL;
       inherit perl;
       inherit (gst_all_1) gstreamer gst-plugins-base;
     });
@@ -10906,7 +10906,7 @@ with pkgs;
       bison = bison2; # error: too few arguments to function 'int yylex(...
       inherit cups;
       harfbuzz = harfbuzz-icu;
-      mesa = mesa_noglu;
+      inherit libGL;
       inherit perl;
       inherit (gst_all_1) gstreamer gst-plugins-base;
       inherit (gnome3) gtk3 dconf;
@@ -10921,7 +10921,7 @@ with pkgs;
       bison = bison2; # error: too few arguments to function 'int yylex(...
       inherit cups;
       harfbuzz = harfbuzz-icu;
-      mesa = mesa_noglu;
+      inherit libGL;
       inherit perl;
       inherit (gst_all_1) gstreamer gst-plugins-base;
       inherit (gnome3) gtk3 dconf;
@@ -11172,7 +11172,7 @@ with pkgs;
   schroedinger = callPackage ../development/libraries/schroedinger { };
 
   SDL = callPackage ../development/libraries/SDL {
-    openglSupport = mesaSupported;
+    openglSupport = libGLSupported;
     alsaSupport = stdenv.isLinux;
     x11Support = !stdenv.isCygwin;
     pulseaudioSupport = config.pulseaudio or stdenv.isLinux;
@@ -11196,7 +11196,7 @@ with pkgs;
   SDL_ttf = callPackage ../development/libraries/SDL_ttf { };
 
   SDL2 = callPackage ../development/libraries/SDL2 {
-    openglSupport = mesaSupported;
+    openglSupport = libGLSupported;
     alsaSupport = stdenv.isLinux;
     x11Support = !stdenv.isCygwin;
     waylandSupport = stdenv.isLinux;
@@ -18887,7 +18887,7 @@ with pkgs;
   racer = callPackage ../games/racer { };
 
   residualvm = callPackage ../games/residualvm {
-    openglSupport = mesaSupported;
+    openglSupport = libGLSupported;
   };
 
   rftg = callPackage ../games/rftg { };