summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2017-11-06 20:56:48 +0000
committerOrivej Desh <orivej@gmx.fr>2017-11-06 20:56:48 +0000
commite4a535afb9e384f836213b8730effb87d3ccfc0a (patch)
tree7ecfe67c3553b86d8d447915e9839c1cf6805a93 /pkgs/top-level
parente734ecb1e81224b0fe8b12cb16bed25b2d23f034 (diff)
downloadnixlib-e4a535afb9e384f836213b8730effb87d3ccfc0a.tar
nixlib-e4a535afb9e384f836213b8730effb87d3ccfc0a.tar.gz
nixlib-e4a535afb9e384f836213b8730effb87d3ccfc0a.tar.bz2
nixlib-e4a535afb9e384f836213b8730effb87d3ccfc0a.tar.lz
nixlib-e4a535afb9e384f836213b8730effb87d3ccfc0a.tar.xz
nixlib-e4a535afb9e384f836213b8730effb87d3ccfc0a.tar.zst
nixlib-e4a535afb9e384f836213b8730effb87d3ccfc0a.zip
Revert "pythonpackages.redNotebook: Remove outdated package"
This reverts commit 33a56ef0a68cc06298556d866b24f1f2a8286639.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index d76c836734c6..e8b8bf440360 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -22735,6 +22735,29 @@ EOF
     };
   };
 
+
+  redNotebook = buildPythonPackage rec {
+    name = "rednotebook-1.8.1";
+
+    src = pkgs.fetchurl {
+      url = "mirror://sourceforge/rednotebook/${name}.tar.gz";
+      sha256 = "00b7s4xpqpxsbzjvjx9qsx5d84m9pvn383c5di1nsfh35pig0rzn";
+    };
+
+    # no tests available
+    doCheck = false;
+
+    propagatedBuildInputs = with self; [ pygtk pywebkitgtk pyyaml chardet ];
+
+    meta = {
+      homepage = http://rednotebook.sourceforge.net/index.html;
+      description = "A modern journal that includes a calendar navigation, customizable templates, export functionality and word clouds";
+      license = licenses.gpl2;
+      maintainers = with maintainers; [ tstrobel ];
+    };
+  };
+
+
   uncertainties = callPackage ../development/python-modules/uncertainties { };
 
   funcy = buildPythonPackage rec {