summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2015-03-26 10:23:55 +0100
committerDomen Kožar <domen@dev.si>2015-03-26 10:25:58 +0100
commite42547d8e9f6cf04a6969c7b486b72da3e17cb90 (patch)
tree719cc79f9d0512b2799715188a5447445bf2a0dc /pkgs/top-level
parentcbb14299c935c5a6a58f5cdd4775273af4a897c1 (diff)
downloadnixlib-e42547d8e9f6cf04a6969c7b486b72da3e17cb90.tar
nixlib-e42547d8e9f6cf04a6969c7b486b72da3e17cb90.tar.gz
nixlib-e42547d8e9f6cf04a6969c7b486b72da3e17cb90.tar.bz2
nixlib-e42547d8e9f6cf04a6969c7b486b72da3e17cb90.tar.lz
nixlib-e42547d8e9f6cf04a6969c7b486b72da3e17cb90.tar.xz
nixlib-e42547d8e9f6cf04a6969c7b486b72da3e17cb90.tar.zst
nixlib-e42547d8e9f6cf04a6969c7b486b72da3e17cb90.zip
pythonPackages.subunit: rewrite to use buildPythonPackage
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 8281c25e4ea4..a79d9d296cc1 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -10866,21 +10866,17 @@ let
   });
 
 
-  subunit = stdenv.mkDerivation rec {
+  subunit = buildPythonPackage rec {
     name = "subunit-${version}";
-    version = "1.0.0";
+    version = "1.1.0";
 
     src = pkgs.fetchurl {
-      url = "https://launchpad.net/subunit/trunk/${version}/+download/${name}.tar.gz";
-      sha256 = "1fnhrrwww90746an2nz2kn9qdf9pklmaf5lm22gssl6648f2rp2m";
+      url = "https://pypi.python.org/packages/source/p/python-subunit/python-subunit-${version}.tar.gz";
+      sha256 = "125zh5i1f21ficn8ix5q33jk87j2pfmzbw6jq5l8v0hhjrp619yr";
     };
 
-    buildInputs = (with pkgs; [ pkgconfig check cppunit perl ]) ++ [ self.wrapPython ];
-
     propagatedBuildInputs = with self; [ testtools testscenarios ];
 
-    postFixup = "wrapPythonPrograms";
-
     meta = {
       description = "A streaming protocol for test results";
       homepage = https://launchpad.net/subunit;