summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-01-20 12:53:46 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-01-20 12:53:46 +0100
commite3581626ef8c31d5a3d31a82135f8bc6e5c2444a (patch)
tree99329f0b96181b5b300e0fedc98abbaf42ceb642 /pkgs/top-level
parent24e2e6d67dafd346ac19523de1345ef130a9cd7d (diff)
downloadnixlib-e3581626ef8c31d5a3d31a82135f8bc6e5c2444a.tar
nixlib-e3581626ef8c31d5a3d31a82135f8bc6e5c2444a.tar.gz
nixlib-e3581626ef8c31d5a3d31a82135f8bc6e5c2444a.tar.bz2
nixlib-e3581626ef8c31d5a3d31a82135f8bc6e5c2444a.tar.lz
nixlib-e3581626ef8c31d5a3d31a82135f8bc6e5c2444a.tar.xz
nixlib-e3581626ef8c31d5a3d31a82135f8bc6e5c2444a.tar.zst
nixlib-e3581626ef8c31d5a3d31a82135f8bc6e5c2444a.zip
python.pkgs.secp256k1: move expression
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix35
1 files changed, 2 insertions, 33 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index d7f204f324cd..39c3ebdf4083 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -16746,39 +16746,8 @@ in {
     };
   };
 
-  secp256k1 = buildPythonPackage rec {
-    name = "secp256k1-${version}";
-    version = "0.12.1";
-
-    src = pkgs.fetchurl {
-      url = "mirror://pypi/s/secp256k1/${name}.tar.gz";
-      sha256 = "0zrjxvzxqm4bz2jcy8sras8jircgbs6dkrw8j3nc6jhvzlikwwxl";
-    };
-
-    nativeBuildInputs = [ pkgs.pkgconfig ];
-    buildInputs = [ self.pytest_28 self.pytestrunner ];
-    propagatedBuildInputs = [ self.cffi pkgs.secp256k1 ];
-
-    # Tests are not included in archive
-    doCheck = false;
-
-    preConfigure = ''
-      cp -r ${pkgs.secp256k1.src} libsecp256k1
-      touch libsecp256k1/autogen.sh
-      export INCLUDE_DIR=${pkgs.secp256k1}/include
-      export LIB_DIR=${pkgs.secp256k1}/lib
-    '';
-
-    checkPhase = ''
-      py.test tests
-    '';
-
-    meta = {
-      homepage = https://github.com/ludbb/secp256k1-py;
-      description = "Python FFI bindings for secp256k1";
-      license = with licenses; [ mit ];
-      maintainers = with maintainers; [ chris-martin ];
-    };
+  secp256k1 = callPackage ../development/python-modules/secp256k1 {
+    inherit (pkgs) secp256k1 pkgconfig;
   };
 
   semantic-version = callPackage ../development/python-modules/semantic-version { };