summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2007-01-15 09:20:18 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2007-01-15 09:20:18 +0000
commite18bd5af62d1c639ead83e79279a08366de34ea5 (patch)
tree43a3d3c9ed44c9c6961893522c3cd6724300b83e /pkgs/top-level
parenta6338f1f34fd6e458e7283a9639573efe1942477 (diff)
downloadnixlib-e18bd5af62d1c639ead83e79279a08366de34ea5.tar
nixlib-e18bd5af62d1c639ead83e79279a08366de34ea5.tar.gz
nixlib-e18bd5af62d1c639ead83e79279a08366de34ea5.tar.bz2
nixlib-e18bd5af62d1c639ead83e79279a08366de34ea5.tar.lz
nixlib-e18bd5af62d1c639ead83e79279a08366de34ea5.tar.xz
nixlib-e18bd5af62d1c639ead83e79279a08366de34ea5.tar.zst
nixlib-e18bd5af62d1c639ead83e79279a08366de34ea5.zip
* Move cleanSource to lib.
svn path=/nixpkgs/trunk/; revision=7668
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index c3881bebd7ce..49c881c98125 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -121,6 +121,8 @@ rec {
 
   useFromStdenv = hasIt: it: alternative: if hasIt then it else alternative;
 
+  lib = library;
+
   library = import ../lib;
 
   # Return an attribute from the Nixpkgs configuration file, or
@@ -204,11 +206,6 @@ rec {
   # derivations, e.g., "... ${somePkg}/bin/foo ...".
   writeText = name: text: runCommand name {inherit text;} "echo \"$text\" > $out";
 
-  # Bring in a path as a source, filtering out all hidden Subversion
-  # directories.  TODO: filter out backup files (*~) etc.
-  cleanSource = src: builtins.filterSource
-    (name: baseNameOf (toString name) != ".svn") src;
-  
   substituteAll = import ../build-support/substitute/substitute-all.nix {
     inherit stdenv;
   };