summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMichael Brantley <limeytexan@gmail.com>2018-05-10 06:47:31 -0400
committerRobert Helgesson <robert@rycee.net>2018-05-10 16:06:36 +0200
commitd4e71a2321f04b590d58eb2292934214c20a4bca (patch)
treefc7170a9625f0faeea0f7dafa5fa635e8724260e /pkgs/top-level
parent07dc607a8d909e69548e49589f58aa53126e1ce1 (diff)
downloadnixlib-d4e71a2321f04b590d58eb2292934214c20a4bca.tar
nixlib-d4e71a2321f04b590d58eb2292934214c20a4bca.tar.gz
nixlib-d4e71a2321f04b590d58eb2292934214c20a4bca.tar.bz2
nixlib-d4e71a2321f04b590d58eb2292934214c20a4bca.tar.lz
nixlib-d4e71a2321f04b590d58eb2292934214c20a4bca.tar.xz
nixlib-d4e71a2321f04b590d58eb2292934214c20a4bca.tar.zst
nixlib-d4e71a2321f04b590d58eb2292934214c20a4bca.zip
perlPackages.Paranoid: init at 2.05
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/perl-packages.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/pkgs/top-level/perl-packages.nix b/pkgs/top-level/perl-packages.nix
index 22733443ed19..5237f2a2c8e1 100644
--- a/pkgs/top-level/perl-packages.nix
+++ b/pkgs/top-level/perl-packages.nix
@@ -11954,6 +11954,25 @@ let self = _self // overrides; _self = with self; {
      };
   };
 
+  Paranoid = buildPerlPackage rec {
+    name = "Paranoid-2.05";
+    src = fetchurl {
+      url = "mirror://cpan/authors/id/C/CO/CORLISS/Paranoid/${name}.tar.gz";
+      sha256 = "583dfa0279733531f360795ad1cf4aa652d537b2b0bbd3c6925d0c8d75cbb3df";
+    };
+    patches = [ ../development/perl-modules/Paranoid-blessed-path.patch ];
+    preConfigure = ''
+      # Capture the path used when compiling this module as the "blessed"
+      # system path, analogous to the module's own use of '/bin:/sbin'.
+      sed -i "s#__BLESSED_PATH__#$PATH#" lib/Paranoid.pm t/01_init_core.t
+    '';
+    meta = {
+      description = "General function library for safer, more secure programming";
+      license = with stdenv.lib.licenses; [ artistic1 gpl1Plus ];
+      maintainers = [ maintainers.limeytexan ];
+    };
+  };
+
   PARDist = buildPerlPackage {
     name = "PAR-Dist-0.49";
     src = fetchurl {