summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2015-09-09 17:23:31 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2015-11-16 12:56:33 +0100
commitce41204fa01b1afd04c1dad1c89157003d546a24 (patch)
treea0da6977e16b77f2fc0bf81f155ba4e89acb4e51 /pkgs/top-level
parent7ae05edcdd14f6ace83ead9bf0d114e97c89a83a (diff)
downloadnixlib-ce41204fa01b1afd04c1dad1c89157003d546a24.tar
nixlib-ce41204fa01b1afd04c1dad1c89157003d546a24.tar.gz
nixlib-ce41204fa01b1afd04c1dad1c89157003d546a24.tar.bz2
nixlib-ce41204fa01b1afd04c1dad1c89157003d546a24.tar.lz
nixlib-ce41204fa01b1afd04c1dad1c89157003d546a24.tar.xz
nixlib-ce41204fa01b1afd04c1dad1c89157003d546a24.tar.zst
nixlib-ce41204fa01b1afd04c1dad1c89157003d546a24.zip
python-packages statsmodels: init at 0.6.1
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index f9c9a6698f1d..cca31f0ab79c 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -16665,6 +16665,30 @@ let
     };
   };
 
+  statsmodels = buildPythonPackage rec {
+    name = "statsmodels-${version}";
+    version = "0.6.1";
+
+    src = pkgs.fetchurl {
+      url = "https://pypi.python.org/packages/source/s/statsmodels/${name}.tar.gz";
+      sha256 = "be4e44374aec9e848b73e5a230dee190ac0c4519e1d40f69a5813190b13ec676";
+    };
+
+    buildInputs = with self; [ nose ];
+    propagatedBuildInputs = with self; [numpy scipy pandas patsy cython matplotlib];
+
+    meta = {
+      description = "Statistical computations and models for use with SciPy";
+      homepage = "https://www.github.com/statsmodels/statsmodels";
+      license = licenses.bsd3;
+      maintainer = with maintainers; [ fridh ];
+    };
+    
+    # Many tests fail when using latest numpy and pandas.
+    # See also https://github.com/statsmodels/statsmodels/issues/2602
+    doCheck = false;
+  };
+
   python_statsd = buildPythonPackage rec {
     name = "python-statsd-${version}";
     version = "1.6.0";
@@ -16681,6 +16705,7 @@ let
       description = "A client for Etsy's node-js statsd server";
       homepage = https://github.com/WoLpH/python-statsd;
       license = licenses.bsd3;
+      maintainers = with maintainers; [ fridh ];
     };
   };