summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2018-03-08 13:56:36 -0500
committerShea Levy <shea@shealevy.com>2018-03-08 13:56:36 -0500
commitc69d8bf5e606915820b30d6db8fa9dfa39766f67 (patch)
tree2a183cea5326f2095b082f4ac274c553faf35c53 /pkgs/top-level
parentfe565510cb6d090b19e7a263133ca1a841135c9b (diff)
downloadnixlib-c69d8bf5e606915820b30d6db8fa9dfa39766f67.tar
nixlib-c69d8bf5e606915820b30d6db8fa9dfa39766f67.tar.gz
nixlib-c69d8bf5e606915820b30d6db8fa9dfa39766f67.tar.bz2
nixlib-c69d8bf5e606915820b30d6db8fa9dfa39766f67.tar.lz
nixlib-c69d8bf5e606915820b30d6db8fa9dfa39766f67.tar.xz
nixlib-c69d8bf5e606915820b30d6db8fa9dfa39766f67.tar.zst
nixlib-c69d8bf5e606915820b30d6db8fa9dfa39766f67.zip
treewide: Remove gnat support.
See discussion in https://github.com/NixOS/nixpkgs/commit/6ac7b19c978e951c124c5ea434c94f95f593888e.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix47
-rw-r--r--pkgs/top-level/release-small.nix1
2 files changed, 0 insertions, 48 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 63f9c1686a70..d5ac725f90d7 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -5958,20 +5958,6 @@ with pkgs;
     inherit binutils;
   };
 
-  gcc45 = lowPrio (wrapCC (callPackage ../development/compilers/gcc/4.5 {
-    inherit noSysDirs;
-    texinfo = texinfo4;
-
-    ppl = null;
-    cloogppl = null;
-
-    # bootstrapping a profiled compiler does not work in the sheevaplug:
-    # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43944
-    profiledCompiler = !stdenv.isArm;
-
-    libcCross = if targetPlatform != buildPlatform then libcCross else null;
-  }));
-
   gcc48 = lowPrio (wrapCC (callPackage ../development/compilers/gcc/4.8 {
     inherit noSysDirs;
 
@@ -6096,23 +6082,6 @@ with pkgs;
     inherit (gnome2) libart_lgpl;
   });
 
-  gnat = gnat45; # failed to make 4.6 or 4.8 build
-
-  gnat45 = wrapCC (gcc45.cc.override {
-    name = "gnat";
-    langCC = false;
-    langC = true;
-    langAda = true;
-    profiledCompiler = false;
-    inherit gnatboot;
-    # We can't use the ppl stuff, because we would have
-    # libstdc++ problems.
-    cloogppl = null;
-    ppl = null;
-  });
-
-  gnatboot = wrapGCC-old (callPackage ../development/compilers/gnatboot {});
-
   gnu-smalltalk = callPackage ../development/compilers/gnu-smalltalk {
     emacsSupport = config.emacsSupport or false;
   };
@@ -6126,14 +6095,6 @@ with pkgs;
     profiledCompiler = false;
   });
 
-  ghdl_mcode = callPackage_i686 ../development/compilers/ghdl {
-    flavour = "mcode";
-  };
-
-  ghdl_llvm = callPackage ../development/compilers/ghdl {
-    flavour = "llvm";
-  };
-
   gcl = callPackage ../development/compilers/gcl {
     gmp = gmp4;
   };
@@ -6791,14 +6752,6 @@ with pkgs;
     bintools = if targetPlatform.isDarwin then darwin.binutils else binutils;
     libc = if targetPlatform != hostPlatform then libcCross else stdenv.cc.libc;
   };
-  # legacy version, used for gnat bootstrapping
-  wrapGCC-old = baseGCC: callPackage ../build-support/gcc-wrapper-old {
-    nativeTools = stdenv.cc.nativeTools or false;
-    nativeLibc = stdenv.cc.nativeLibc or false;
-    nativePrefix = stdenv.cc.nativePrefix or "";
-    gcc = baseGCC;
-    libc = glibc;
-  };
 
   wrapBintoolsWith = { bintools, libc }: bintoolsWrapperFun {
     nativeTools = targetPlatform == hostPlatform && stdenv.cc.nativeTools or false;
diff --git a/pkgs/top-level/release-small.nix b/pkgs/top-level/release-small.nix
index 391d79e47f18..ca4036dad80b 100644
--- a/pkgs/top-level/release-small.nix
+++ b/pkgs/top-level/release-small.nix
@@ -48,7 +48,6 @@ with import ./release-lib.nix { inherit supportedSystems; };
   gcj = linux;
   glibc = linux;
   glibcLocales = linux;
-  gnat = linux;
   gnugrep = all;
   gnum4 = all;
   gnumake = all;