summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authoraszlig <aszlig@nix.build>2017-11-09 07:31:26 +0100
committeraszlig <aszlig@nix.build>2017-11-09 07:35:43 +0100
commitc1d12e11200cb383491d6f6cd1d53d2d6dc15aca (patch)
tree9b5958d23d3d5321b95506f625ea47a0c01e3850 /pkgs/top-level
parent72450025dd351a185dddf4918e31143bcaf04515 (diff)
downloadnixlib-c1d12e11200cb383491d6f6cd1d53d2d6dc15aca.tar
nixlib-c1d12e11200cb383491d6f6cd1d53d2d6dc15aca.tar.gz
nixlib-c1d12e11200cb383491d6f6cd1d53d2d6dc15aca.tar.bz2
nixlib-c1d12e11200cb383491d6f6cd1d53d2d6dc15aca.tar.lz
nixlib-c1d12e11200cb383491d6f6cd1d53d2d6dc15aca.tar.xz
nixlib-c1d12e11200cb383491d6f6cd1d53d2d6dc15aca.tar.zst
nixlib-c1d12e11200cb383491d6f6cd1d53d2d6dc15aca.zip
python/pyinsane2: 2.0.9 -> 2.0.10
Upstream changes:

  * Now works with 'setup.py develop' (thanks to Matthieu Coudron)
  * WIA: Some drivers (Lexmark for instance) returns
    WIA_ERROR_PAPER_EMPTY when calling transfer->Download() instead of
    returning a shorted image (like HP)
  * MacOSX + Sane: disable dedicated process workaround (doesn't work)
  * WIA: Minor optimisation (Use collections.deque() instead of
    list.pop())
  * Sane/exit(): Exit gracefully

Full changelog can be found at:

https://github.com/openpaperwork/pyinsane/blob/2.0.10/ChangeLog

Tested by building and running a few scans.

Signed-off-by: aszlig <aszlig@nix.build>
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index c1578987570b..c9edff833f52 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -16043,21 +16043,21 @@ in {
 
   pyinsane2 = buildPythonPackage rec {
     name = "pyinsane2-${version}";
-    version = "2.0.9";
+    version = "2.0.10";
 
     src = pkgs.fetchurl {
       url = "mirror://pypi/p/pyinsane2/${name}.tar.gz";
-      sha256 = "1g4a1zhrrs7smmnsm7x8j5lvsz0r6rr2jgjykc9c1jlscz3yr747";
+      sha256 = "00d1wqb3w9bn1rxb2dwmdqbar2lr96izq855l5vzprc17dkgip3j";
     };
 
     postPatch = ''
       # pyinsane2 forks itself, so we need to re-inject the PYTHONPATH.
       sed -i -e '/os.putenv.*PYINSANE_DAEMON/ {
         a \        os.putenv("PYTHONPATH", ":".join(sys.path))
-      }' src/pyinsane2/sane/abstract_proc.py
+      }' pyinsane2/sane/abstract_proc.py
 
       sed -i -e 's,"libsane.so.1","${pkgs.sane-backends}/lib/libsane.so",' \
-        src/pyinsane2/sane/rawapi.py
+        pyinsane2/sane/rawapi.py
     '';
 
     # Tests require a scanner to be physically connected, so let's just do a