summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFernando J Pando <fernando.pando@stelligent.com>2016-08-30 10:48:58 -0400
committerFrederik Rietdijk <fridh@fridh.nl>2016-09-01 10:56:29 +0200
commitbea6b4b36fc98b7419856a64649d10ffa6d71bdb (patch)
tree6ba5df2b45aa69dc5f8399c4fa280fe219a5ba09 /pkgs/top-level
parent47a2a15013b922f1b0e213892ebdcec9ef207475 (diff)
downloadnixlib-bea6b4b36fc98b7419856a64649d10ffa6d71bdb.tar
nixlib-bea6b4b36fc98b7419856a64649d10ffa6d71bdb.tar.gz
nixlib-bea6b4b36fc98b7419856a64649d10ffa6d71bdb.tar.bz2
nixlib-bea6b4b36fc98b7419856a64649d10ffa6d71bdb.tar.lz
nixlib-bea6b4b36fc98b7419856a64649d10ffa6d71bdb.tar.xz
nixlib-bea6b4b36fc98b7419856a64649d10ffa6d71bdb.tar.zst
nixlib-bea6b4b36fc98b7419856a64649d10ffa6d71bdb.zip
pythonPackages.isort: 4.2.2 -> 4.2.5
Tested on Linux
- python 2.7
- python 3.5
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 9f2e4662b62b..3eebe1366b3c 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -12196,20 +12196,21 @@ in modules // {
   };
 
   isort = buildPythonPackage rec {
-    name = "isort-4.2.2";
-
+    name = "${pname}-${version}";
+    pname = "isort";
+    version = "4.2.5";
     src = pkgs.fetchurl {
-      url = "mirror://pypi/i/isort/${name}.tar.gz";
-      sha256 = "0xqxnkli3j69mj1m0i1r9n68bfkdxfcgxi602lqgy491m21q1rpj";
+      url = "mirror://pypi/i/${pname}/${name}.tar.gz";
+      sha256 = "0p7a6xaq7zxxq5vr5gizshnsbk2afm70apg97xwfdxiwyi201cjn";
     };
-
     buildInputs = with self; [ mock pytest ];
-
+    # No tests distributed
+    doCheck = false;
     meta = {
       description = "A Python utility / library to sort Python imports";
       homepage = https://github.com/timothycrosley/isort;
       license = licenses.mit;
-      maintainers = with maintainers; [ couchemar ];
+      maintainers = with maintainers; [ couchemar nand0p ];
     };
   };