summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorAllen Nelson <anelson@narrativescience.com>2015-11-03 16:26:29 -0600
committerAllen Nelson <anelson@narrativescience.com>2015-11-03 16:26:29 -0600
commitb8c784f061e5153f61332ce65c335a42c0ab7702 (patch)
treeb2a11138717e4616f8d047d55c2ecf9db4ce9224 /pkgs/top-level
parent58b862b750dbfe00bc3e935f5ac8857b2fd6a591 (diff)
downloadnixlib-b8c784f061e5153f61332ce65c335a42c0ab7702.tar
nixlib-b8c784f061e5153f61332ce65c335a42c0ab7702.tar.gz
nixlib-b8c784f061e5153f61332ce65c335a42c0ab7702.tar.bz2
nixlib-b8c784f061e5153f61332ce65c335a42c0ab7702.tar.lz
nixlib-b8c784f061e5153f61332ce65c335a42c0ab7702.tar.xz
nixlib-b8c784f061e5153f61332ce65c335a42c0ab7702.tar.zst
nixlib-b8c784f061e5153f61332ce65c335a42c0ab7702.zip
patch to remove large file test in numpy
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index f6ad5d2a8974..5550b09645eb 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -10202,6 +10202,12 @@ let
     buildInputs = [ pkgs.gfortran self.nose ];
     propagatedBuildInputs = [ support.openblas ];
 
+    # This patch removes the test of large file support, which takes forever
+    # and can cause the machine to run out of disk space when run.
+    patchPhase = ''
+      patch -p0 < ${../development/python-modules/numpy-no-large-files.patch}
+    '';
+
     meta = {
       description = "Scientific tools for Python";
       homepage = "http://numpy.scipy.org/";