summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2018-03-23 23:56:45 +0100
committerRok Garbas <rok@garbas.si>2018-03-27 19:24:16 +0200
commitb71ffc1b25b46297f1e52fd0c0ac491d296160f2 (patch)
tree1df1265331372a2fa0fd55a8678eefeb3d941d20 /pkgs/top-level
parent95a819c0026a7a3c0dd2099e1c53fea95430c505 (diff)
downloadnixlib-b71ffc1b25b46297f1e52fd0c0ac491d296160f2.tar
nixlib-b71ffc1b25b46297f1e52fd0c0ac491d296160f2.tar.gz
nixlib-b71ffc1b25b46297f1e52fd0c0ac491d296160f2.tar.bz2
nixlib-b71ffc1b25b46297f1e52fd0c0ac491d296160f2.tar.lz
nixlib-b71ffc1b25b46297f1e52fd0c0ac491d296160f2.tar.xz
nixlib-b71ffc1b25b46297f1e52fd0c0ac491d296160f2.tar.zst
nixlib-b71ffc1b25b46297f1e52fd0c0ac491d296160f2.zip
qpid-cpp: fix build
The compilation broke due to the flag `-Werror=int-in-bool-context`
which caused several compilation errors with GCC v7. Disabling this
warning manually with `-Wno-error` in `NIX_CFLAGS_COMPILE` should be
fine.

This package experienced several radical changes as the entire python
build in `$src/management/python` was broken since the given Python
interpreter missed several needed modules (including
`pythonPackages.qpid-python`). As the CMake build tried to invoke the
affected `setup.py` manually and patched the shebangs with `disutil` and
caused non-functional executables, I split the package up into two
parts, the actual `qpid-cpp` lib and the Python module that will be
composed using `buildEnv`.

Furthermore I added myself as maintainer for the package as the diff
became quite huge and we should have more folks available to maintain
this.

See https://hydra.nixos.org/build/71519082/log
See tickets #36453 and #31747
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 0b4215a31ff4..be6957c7a572 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -12716,6 +12716,7 @@ with pkgs;
 
   qpid-cpp = callPackage ../servers/amqp/qpid-cpp {
     boost = boost155;
+    inherit (pythonPackages) buildPythonPackage qpid-python;
   };
 
   quagga = callPackage ../servers/quagga { };