summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-01-07 22:47:30 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-01-07 22:47:30 +0000
commita4473b8205a3f3c980c06e3c7210c2764f4577b8 (patch)
tree469d50873647a7f6fcfd06a839076a6e2cc385f2 /pkgs/top-level
parentde6f1897438dcdc3c078236a81c094ba1389a76e (diff)
downloadnixlib-a4473b8205a3f3c980c06e3c7210c2764f4577b8.tar
nixlib-a4473b8205a3f3c980c06e3c7210c2764f4577b8.tar.gz
nixlib-a4473b8205a3f3c980c06e3c7210c2764f4577b8.tar.bz2
nixlib-a4473b8205a3f3c980c06e3c7210c2764f4577b8.tar.lz
nixlib-a4473b8205a3f3c980c06e3c7210c2764f4577b8.tar.xz
nixlib-a4473b8205a3f3c980c06e3c7210c2764f4577b8.tar.zst
nixlib-a4473b8205a3f3c980c06e3c7210c2764f4577b8.zip
Adding calibre. This involved also:
- Adding podofo
- Adding some new python packages
- Making new pkgs attributes for python packages to build with python 2.6
- Updating some python packages expressions to allow python 2.6, and not only 2.5.


svn path=/nixpkgs/trunk/; revision=19303
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix52
-rw-r--r--pkgs/top-level/python-packages.nix38
2 files changed, 88 insertions, 2 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 81305572a865..bb05a1c1302d 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -2373,6 +2373,7 @@ let
 
   python = if getConfig ["python" "full"] false then pythonFull else pythonBase;
   python25 = if getConfig ["python" "full"] false then python25Full else python25Base;
+  python26 = if getConfig ["python" "full"] false then python26Full else python26Base;
   pythonBase = python25Base;
   pythonFull = python25Full;
 
@@ -4353,6 +4354,11 @@ let
     inherit (xlibs) libXi libSM libXmu libXext libX11;
   };
 
+  podofo = import ../development/libraries/podofo {
+    inherit fetchurl stdenv cmake zlib freetype libjpeg libtiff
+      fontconfig openssl;
+  };
+
   polkit = import ../development/libraries/polkit {
     inherit stdenv fetchurl pkgconfig eggdbus expat pam intltool gettext glib;
   };
@@ -4831,8 +4837,21 @@ let
       inherit python setuptools makeWrapper lib;
     };
 
+  buildPython26Package =
+    import ../development/python-modules/generic {
+      inherit makeWrapper lib;
+      python = python26;
+      setuptools = setuptools_python26;
+    };
+
   pythonPackages = recurseIntoAttrs (import ./python-packages.nix {
+    inherit pkgs python buildPythonPackage;
+  });
+
+  python26Packages = recurseIntoAttrs (import ./python-packages.nix {
     inherit pkgs;
+    python = python26;
+    buildPythonPackage = buildPython26Package;
   });
 
   foursuite = import ../development/python-modules/4suite {
@@ -4857,6 +4876,11 @@ let
     inherit fetchurl stdenv python zlib libjpeg freetype;
   };
 
+  pil_python26 = import ../development/python-modules/pil {
+    inherit fetchurl stdenv zlib libjpeg freetype;
+    python = python26;
+  };
+
   psyco = import ../development/python-modules/psyco {
       inherit fetchurl stdenv python;
     };
@@ -4913,6 +4937,11 @@ let
     inherit stdenv fetchurl lib python;
   };
 
+  sip_python26 = import ../development/python-modules/python-sip {
+    inherit stdenv fetchurl lib;
+    python = python26;
+  };
+
   pyqt = builderDefsPackage (import ../development/python-modules/pyqt/4.3.3.nix) {
     inherit pkgconfig python pythonSip glib;
     inherit (xlibs) libX11 libXext;
@@ -4924,6 +4953,13 @@ let
     qt4 = qt45;
   };
 
+  pyqt4_python26 = import ../development/python-modules/pyqt {
+    inherit stdenv fetchurl lib;
+    qt4 = qt45;
+    python = python26;
+    sip = sip_python26;
+  };
+
   pyx = import ../development/python-modules/pyx {
     inherit fetchurl stdenv python makeWrapper;
   };
@@ -4936,6 +4972,11 @@ let
     inherit python makeWrapper;
   };
 
+  setuptools_python26 = builderDefsPackage (import ../development/python-modules/setuptools) {
+    inherit makeWrapper;
+    python = python26;
+  };
+
   wxPython = wxPython26;
 
   wxPython26 = import ../development/python-modules/wxPython/2.6.nix {
@@ -6325,6 +6366,17 @@ let
     inherit fetchurl stdenv ncurses;
   };
 
+  calibre = import ../applications/misc/calibre {
+    inherit stdenv fetchurl libpng imagemagick pkgconfig libjpeg fontconfig podofo
+      qt4 makeWrapper unrar;
+    python = python26Full;
+    pyqt4 = pyqt4_python26;
+    sip = sip_python26;
+    pil = pil_python26;
+    popplerQt4 = popplerQt45;
+    inherit (python26Packages) mechanize lxml dateutil;
+  };
+
   carrier = builderDefsPackage (import ../applications/networking/instant-messengers/carrier/2.5.0.nix) {
     inherit fetchurl stdenv pkgconfig perl perlXMLParser libxml2 openssl nss
       gtkspell aspell gettext ncurses avahi dbus dbus_glib python
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 0dddb832ab77..80db6fb4127b 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -1,7 +1,7 @@
-{ pkgs }:
+{ pkgs, python, buildPythonPackage }:
 
 rec {
-  inherit (pkgs) buildPythonPackage fetchurl fetchsvn stdenv python;
+  inherit (pkgs) fetchurl fetchsvn stdenv;
 
   argparse = buildPythonPackage (rec {
     name = "argparse-0.9.1";
@@ -53,6 +53,23 @@ rec {
     };
   });
 
+  dateutil = buildPythonPackage (rec {
+    name = "python-dateutil-1.4.1";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/p/python-dateutil/${name}.tar.gz";
+      sha256 = "0mrkh932k8s74h4rpgksvpmwbrrkq8zn78gbgwc22i2vlp31bdkl";
+    };
+
+    meta = {
+      description = "Powerful extensions to the standard datetime module";
+
+      homepage = http://pypi.python.org/pypi/python-dateutil;
+
+      license = "BSD-style";
+    };
+  });
+
   foolscap = buildPythonPackage (rec {
     name = "foolscap-0.4.2";
 
@@ -143,6 +160,23 @@ rec {
     };
   });
 
+  mechanize = buildPythonPackage (rec {
+    name = "mechanize-0.1.11";
+
+    src = fetchurl {
+      url = "mirror://sourceforge/wwwsearch/${name}.tar.gz";
+      sha256 = "1h62mwy4iz09jqz17nrb9j8y0djd500zdfqwrz9xmdwqzqwixkj2";
+    };
+
+    meta = {
+      description = "Stateful programmatic web browsing in Python";
+
+      homepage = http://wwwsearch.sourceforge.net/;
+
+      license = "BSD-style";
+    };
+  });
+
   namebench = buildPythonPackage (rec {
     name = "namebench-1.0.5";