summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorDomen Kozar <domen@dev.si>2013-02-18 14:08:48 +0100
committerDomen Kozar <domen@dev.si>2013-02-18 14:08:48 +0100
commit9d73b9ca5101856a6e34a65033e69f8baf4df950 (patch)
tree03623a31eab522c1f227f9d9aba9f9a70f293f8b /pkgs/top-level
parent62542a1556efa6c4cc2ac2f141348407bd251e17 (diff)
downloadnixlib-9d73b9ca5101856a6e34a65033e69f8baf4df950.tar
nixlib-9d73b9ca5101856a6e34a65033e69f8baf4df950.tar.gz
nixlib-9d73b9ca5101856a6e34a65033e69f8baf4df950.tar.bz2
nixlib-9d73b9ca5101856a6e34a65033e69f8baf4df950.tar.lz
nixlib-9d73b9ca5101856a6e34a65033e69f8baf4df950.tar.xz
nixlib-9d73b9ca5101856a6e34a65033e69f8baf4df950.tar.zst
nixlib-9d73b9ca5101856a6e34a65033e69f8baf4df950.zip
Add beets and it's dependencies
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix77
1 files changed, 77 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index bf9bea000f8c..19d7930b41ee 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -275,6 +275,29 @@ pythonPackages = python.modules // rec {
     propagatedBuildInputs = [ logilab_common ];
   };
 
+
+  beets = buildPythonPackage rec {
+    name = "beets-1.0.0";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/b/beets/${name}.tar.gz";
+      md5 = "88ad09a93aa0d69ce813205cf23b2a6c";
+    };
+
+    # tests depend on $HOME setting
+    configurePhase = "export HOME=$TMPDIR";
+
+    propagatedBuildInputs = [ pyyaml unidecode mutagen munkres musicbrainzngs python.modules.sqlite3 python.modules.readline ];
+
+    meta = {
+      homepage = http://beets.radbox.org;
+      description = "Music tagger and library organizer";
+      license = pkgs.lib.licenses.mit;
+      maintainers = [ stdenv.lib.maintainers.iElectric ];
+    };
+  };
+
+
   beautifulsoup = buildPythonPackage (rec {
     name = "beautifulsoup-3.0.8";
 
@@ -1624,6 +1647,43 @@ pythonPackages = python.modules // rec {
   };
 
 
+  munkres = buildPythonPackage rec {
+    name = "munkres-1.0.5.4";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/m/munkres/${name}.tar.gz";
+      md5 = "cb9d114fb523428bab4742e88bc83696";
+    };
+
+    # error: invalid command 'test'
+    doCheck = false;
+
+    meta = {
+      homepage = http://bmc.github.com/munkres/;
+      description = "Munkres algorithm for the Assignment Problem";
+      license = pkgs.lib.licenses.bsd3;
+      maintainers = [ stdenv.lib.maintainers.iElectric ];
+    };
+  };
+
+
+  musicbrainzngs = buildPythonPackage rec {
+    name = "musicbrainzngs-0.2";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/m/musicbrainzngs/${name}.tar.gz";
+      md5 = "bc32aa1cf121f29c3ca1c06e9668865f";
+    };
+
+    meta = {
+      homepage = http://alastair/python-musicbrainz-ngs;
+      description = "Python bindings for musicbrainz NGS webservice";
+      license = pkgs.lib.licenses.bsd2;
+      maintainers = [ stdenv.lib.maintainers.iElectric ];
+    };
+  };
+
+
   mutagen = buildPythonPackage (rec {
     name = "mutagen-1.20";
 
@@ -4389,6 +4449,23 @@ pythonPackages = python.modules // rec {
     };
   };
 
+
+  unidecode = buildPythonPackage rec {
+    name = "Unidecode-0.04.12";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/U/Unidecode/${name}.tar.gz";
+      md5 = "351dc98f4512bdd2e93f7a6c498730eb";
+    };
+
+    meta = {
+      homepage = http://pypi.python.org/pypi/Unidecode/;
+      description = "ASCII transliterations of Unicode text";
+      license = pkgs.lib.licenses.gplv2;
+      maintainers = [ stdenv.lib.maintainers.iElectric ];
+    };
+  };
+
   txamqp = buildPythonPackage rec {
     name = "txamqp-${version}";
     version = "0.3";