summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMatthew Pickering <matthewtpickering@gmail.com>2018-02-03 18:37:08 +0000
committerMatthew Pickering <matthewtpickering@gmail.com>2018-02-03 18:37:08 +0000
commit9c7c640ae4442fab7f1f67470ccfb92bf6d20529 (patch)
tree9bf757148fd2f082d36ca5af1cf28e5277d2d0fa /pkgs/top-level
parent8b362957c7683571e7bdc8f0672cc5b53f704c75 (diff)
downloadnixlib-9c7c640ae4442fab7f1f67470ccfb92bf6d20529.tar
nixlib-9c7c640ae4442fab7f1f67470ccfb92bf6d20529.tar.gz
nixlib-9c7c640ae4442fab7f1f67470ccfb92bf6d20529.tar.bz2
nixlib-9c7c640ae4442fab7f1f67470ccfb92bf6d20529.tar.lz
nixlib-9c7c640ae4442fab7f1f67470ccfb92bf6d20529.tar.xz
nixlib-9c7c640ae4442fab7f1f67470ccfb92bf6d20529.tar.zst
nixlib-9c7c640ae4442fab7f1f67470ccfb92bf6d20529.zip
osm2xmap: init at 2.0
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 641e859de4b1..0eb4d73bcb08 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -10101,6 +10101,13 @@ with pkgs;
 
   libyamlcpp = callPackage ../development/libraries/libyaml-cpp { };
 
+  libyamlcpp_0_3 = pkgs.libyamlcpp.overrideAttrs (oldAttrs: rec {
+    src = pkgs.fetchurl {
+      url = "https://github.com/jbeder/yaml-cpp/archive/release-0.3.0.tar.gz";
+      sha256 = "12aszqw6svwlnb6nzhsbqhz3c7vnd5ahd0k6xlj05w8lm83hx3db";
+      };
+    });
+
   # interception-tools needs this. This should be removed when there is a new
   # release of libyamlcpp, i.e. when the version of libyamlcpp is newer than
   # 0.5.3.
@@ -16525,6 +16532,10 @@ with pkgs;
     inherit (gnome3) yelp_tools;
   };
 
+  osm2xmap = callPackage ../applications/misc/osm2xmap {
+    libyamlcpp = libyamlcpp_0_3;
+  };
+
   osmctools = callPackage ../applications/misc/osmctools { };
 
   vivaldi = callPackage ../applications/networking/browsers/vivaldi {};
@@ -17463,7 +17474,7 @@ with pkgs;
   testssl = callPackage ../applications/networking/testssl { };
 
   umurmur = callPackage ../applications/networking/umurmur { };
-  
+
   udocker = pythonPackages.callPackage ../tools/virtualization/udocker { };
 
   unigine-valley = callPackage ../applications/graphics/unigine-valley { };