summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2016-08-01 20:35:09 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2016-08-02 14:41:41 +0200
commit99f63b4ded22117186eeba671c1657d155b45a20 (patch)
treefe3b53147b92b181a90d157aaa37992944069bcc /pkgs/top-level
parent35cdfa572bebdf73ca28b82d84d16ddd0d1115fc (diff)
downloadnixlib-99f63b4ded22117186eeba671c1657d155b45a20.tar
nixlib-99f63b4ded22117186eeba671c1657d155b45a20.tar.gz
nixlib-99f63b4ded22117186eeba671c1657d155b45a20.tar.bz2
nixlib-99f63b4ded22117186eeba671c1657d155b45a20.tar.lz
nixlib-99f63b4ded22117186eeba671c1657d155b45a20.tar.xz
nixlib-99f63b4ded22117186eeba671c1657d155b45a20.tar.zst
nixlib-99f63b4ded22117186eeba671c1657d155b45a20.zip
pythonPackages.mutagen: 1.27 -> 1.32
(Not updating to the latest version, 1.34, because it breaks e.g.
'beets'. See https://github.com/beetbox/beets/issues/2153.)

The new version requires locale / i18n to be set-up for tests or else
this message is thrown:

  RuntimeError: This test suite needs a unicode locale encoding. Try setting LANG=C.UTF-8

Also, remove a test that currently fails due to the python builder in
nixpkgs. PR with fix: https://github.com/NixOS/nixpkgs/pull/17430
("python: add file encoding to run_setup.py").
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix17
1 files changed, 14 insertions, 3 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 21617202510e..2e70212bc132 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -13479,15 +13479,26 @@ in modules // {
   };
 
   mutagen = buildPythonPackage (rec {
-    name = "mutagen-1.27";
+    name = "mutagen-1.32";
 
     src = pkgs.fetchurl {
       url = "mirror://pypi/m/mutagen/${name}.tar.gz";
-      sha256 = "cc884fe1e20fe220be7ce7c3b269f4cadc69a8310150a3a41162fba1ca9c88bd";
+      sha256 = "1d9sxl442xjj7pdyjj5h0dsjyd7d3wqswr8icqqgqdmg9k8dw8bp";
     };
 
     # Needed for tests only
-    buildInputs = [ pkgs.faad2 pkgs.flac pkgs.vorbis-tools pkgs.liboggz ];
+    buildInputs = [ pkgs.faad2 pkgs.flac pkgs.vorbis-tools pkgs.liboggz
+      pkgs.glibcLocales
+    ];
+    LC_ALL = "en_US.UTF-8";
+
+    # Remove test that fails due to missing encoding in nix_run_setup.py, a
+    # file that buildPythonPackage copies to source trees at build time.
+    # PR with fix: https://github.com/NixOS/nixpkgs/pull/17430
+    # ("python: add file encoding to run_setup.py")
+    preBuild = ''
+      rm tests/test_encoding.py
+    '';
 
     meta = {
       description = "Python multimedia tagging library";